summary refs log tree commit diff
path: root/hosts/vps/website.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/vps/website.nix')
-rw-r--r--hosts/vps/website.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/hosts/vps/website.nix b/hosts/vps/website.nix
new file mode 100644
index 0000000..156e5da
--- /dev/null
+++ b/hosts/vps/website.nix
@@ -0,0 +1,15 @@
+{ pkgs, config, ... }:
+
+{
+  config = {
+    services.caddy = {
+      enable = true;
+      virtualHosts."https://tzlil.club".extraConfig = ''
+        try_files ${pkgs.writeText "index.html" ''
+          hello world
+        ''} /
+      '';
+    };
+    networking.firewall.allowedTCPPorts = [443];
+  };
+}
\ No newline at end of file