summary refs log tree commit diff
path: root/hosts/vps/website.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-02-09 14:03:19 +0200
committertzlil <tzlils@protonmail.com>2023-02-09 14:03:19 +0200
commit566dc1e8f6e619f590f017a810a8a55d9a90a25c (patch)
tree29ac3794c6b5e1ca07c8a7587c6fb14fb1ddcdb2 /hosts/vps/website.nix
parentb3b78ca3c15bff46eb913e7f0cfebdac71557eea (diff)
add website (caddy) config, add mpd, add pc config, remove 9p mount from run.sh, improve greet mixin
Diffstat (limited to 'hosts/vps/website.nix')
-rw-r--r--hosts/vps/website.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/hosts/vps/website.nix b/hosts/vps/website.nix
new file mode 100644
index 0000000..156e5da
--- /dev/null
+++ b/hosts/vps/website.nix
@@ -0,0 +1,15 @@
+{ pkgs, config, ... }:
+
+{
+  config = {
+    services.caddy = {
+      enable = true;
+      virtualHosts."https://tzlil.club".extraConfig = ''
+        try_files ${pkgs.writeText "index.html" ''
+          hello world
+        ''} /
+      '';
+    };
+    networking.firewall.allowedTCPPorts = [443];
+  };
+}
\ No newline at end of file