summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..d6c6f13
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,17 @@
+[tool.poetry]
+name = "skimap"
+version = "0.1.0"
+description = ""
+authors = ["tzlil <tzlils@protonmail.com>"]
+
+[tool.poetry.dependencies]
+python = "^3.10"
+lambda-calculus = "^3.0.0"
+networkx = "^3.1"
+matplotlib = "^3.7.1"
+pydot = "^1.4.2"
+
+
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"