summary refs log tree commit diff
path: root/profiles/user.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/user.nix')
-rw-r--r--profiles/user.nix10
1 files changed, 4 insertions, 6 deletions
diff --git a/profiles/user.nix b/profiles/user.nix
index 71c6617..97597b0 100644
--- a/profiles/user.nix
+++ b/profiles/user.nix
@@ -3,6 +3,7 @@
   lib,
   config,
   inputs,
+  builtins,
   ...
 }: {
   imports = [
@@ -45,12 +46,9 @@
       };
       programs.ssh = {
         enable = true;
-        knownHosts = {
-          pc = {
-            extraHostNames = [ "100.99.246.128" ];
-            publicKey = "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAINu5lRKb1Ao4uj1tAV10QHKIvXfC8ncQ65b+oJtxrd1e";
-          };
-        };
+        userKnownHostsFile = builtins.toFile "known_hosts" "
+          pc ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAINu5lRKb1Ao4uj1tAV10QHKIvXfC8ncQ65b+oJtxrd1e
+        ";
         matchBlocks."*".identityFile = config.age.secrets."id_ed25519".path;
       };
     };