summary refs log tree commit diff
path: root/profiles/graphical.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/graphical.nix')
-rw-r--r--profiles/graphical.nix39
1 files changed, 23 insertions, 16 deletions
diff --git a/profiles/graphical.nix b/profiles/graphical.nix
index 8ba6e7f..89c88f5 100644
--- a/profiles/graphical.nix
+++ b/profiles/graphical.nix
@@ -6,6 +6,7 @@
   ...
 }: {
   config = {
+    programs.dconf.enable = true;
     home-manager.users.tzlil = {...}: {
       fonts.fontconfig.enable = true;
 
@@ -17,6 +18,12 @@
         noto-fonts-cjk
       ];
 
+      dconf.settings = {
+        "org/gnome/desktop/interface" = {
+          color-scheme = "prefer-dark";
+        };
+      };
+
       # gtk = {
       #   enable = true;
       #   font.name = "Victor Mono SemiBold 12";
@@ -26,22 +33,22 @@
       #   };
       # };
 
-      # gtk = {
-      #   theme.package = pkgs.gnome.gnome-themes-extra;
-      #   theme.name = "Adwaita-dark";
-      #   enable = true;
-      #   gtk3.extraConfig = {
-      #     gtk-application-prefer-dark-theme = 1;
-      #     gtk-xft-hinting = 1;
-      #     gtk-xft-hintstyle = "slight";
-      #     gtk-xft-antialias = 1; # => font-antialiasing="grayscale"
-      #     gtk-xft-rgba = "rgb"; # => font-rgb-order="rgb"
-      #   };
-      #   font = {
-      #     package = pkgs.noto-fonts;
-      #     name = "Noto Sans 11";
-      #   };
-      # };
+      gtk = {
+        theme.package = pkgs.gnome.gnome-themes-extra;
+        theme.name = "Adwaita-dark";
+        enable = true;
+        gtk3.extraConfig = {
+          gtk-application-prefer-dark-theme = 1;
+          gtk-xft-hinting = 1;
+          gtk-xft-hintstyle = "slight";
+          gtk-xft-antialias = 1; # => font-antialiasing="grayscale"
+          gtk-xft-rgba = "rgb"; # => font-rgb-order="rgb"
+        };
+        font = {
+          package = pkgs.noto-fonts;
+          name = "Noto Sans 11";
+        };
+      };
     };
   };
 }