summary refs log tree commit diff
path: root/profiles/gentoo.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/gentoo.nix')
-rw-r--r--profiles/gentoo.nix44
1 files changed, 25 insertions, 19 deletions
diff --git a/profiles/gentoo.nix b/profiles/gentoo.nix
index 9755fd8..337a306 100644
--- a/profiles/gentoo.nix
+++ b/profiles/gentoo.nix
@@ -1,6 +1,10 @@
-{ pkgs, lib, config, inputs, ... }:
-
 {
+  pkgs,
+  lib,
+  config,
+  inputs,
+  ...
+}: {
   imports = [];
   config = {
     nix.binaryCaches = [
@@ -11,21 +15,23 @@
     nix.binaryCachePublicKeys = [
       "gravity.cs.illinois.edu-1:yymmNS/WMf0iTj2NnD0nrVV8cBOXM9ivAkEdO1Lro3U="
     ];
-    
-    nativeStdenv = prev.stdenvAdapters.withCFlags [ "-O3" "-pipe" "-march=native" ]
-    (prev.overrideCC prev.llvmPackages_latest.stdenv
-      (prev.wrapCCWith rec {
-        cc = prev.llvmPackages_latest.clang-unwrapped;
-        bintools = (final.wrapBintoolsWith {
-          coreutils = final.uutils-coreutils;
-          libc = final.musl;
-          bintools = final.binutils-unwrapped.overrideAttrs
-            (old: {
-              postInstall = ''
-                ln -sf ${final.mold}/bin/mold $out/bin/ld
-              '';
-            });
-        });
-      }));
+
+    nativeStdenv =
+      prev.stdenvAdapters.withCFlags ["-O3" "-pipe" "-march=native"]
+      (prev.overrideCC prev.llvmPackages_latest.stdenv
+        (prev.wrapCCWith rec {
+          cc = prev.llvmPackages_latest.clang-unwrapped;
+          bintools = final.wrapBintoolsWith {
+            coreutils = final.uutils-coreutils;
+            libc = final.musl;
+            bintools =
+              final.binutils-unwrapped.overrideAttrs
+              (old: {
+                postInstall = ''
+                  ln -sf ${final.mold}/bin/mold $out/bin/ld
+                '';
+              });
+          };
+        }));
   };
-}
\ No newline at end of file
+}