summary refs log tree commit diff
path: root/mixins/cli.nix
diff options
context:
space:
mode:
Diffstat (limited to 'mixins/cli.nix')
-rw-r--r--mixins/cli.nix13
1 files changed, 9 insertions, 4 deletions
diff --git a/mixins/cli.nix b/mixins/cli.nix
index dbed8fd..db77ab8 100644
--- a/mixins/cli.nix
+++ b/mixins/cli.nix
@@ -5,9 +5,6 @@
   inputs,
   ...
 }: {
-  imports = [
-    inputs.home-manager.nixosModules."home-manager"
-  ];
   config = {
     home-manager.users.tzlil = {
       pkgs,
@@ -15,6 +12,9 @@
       nixosConfig,
       ...
     } @ hm: {
+      imports = [
+        # inputs.viper-nix-common.homeModules.xdg
+      ];
       home = {
         packages = with pkgs; [
           rsync
@@ -22,8 +22,13 @@
           ripgrep
           bat
           croc
+          (pkgs.python3.withPackages (ps: with ps; [
+            requests
+          ]))
         ];
-        # sessionVariables.EDITOR = "nvim";
+        sessionVariables = {
+          EDITOR = "nvim";
+        };
       };
       programs = {
         git = {