summary refs log tree commit diff
path: root/hosts/vps/cfg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/vps/cfg.nix')
-rw-r--r--hosts/vps/cfg.nix39
1 files changed, 19 insertions, 20 deletions
diff --git a/hosts/vps/cfg.nix b/hosts/vps/cfg.nix
index f32afea..25da42b 100644
--- a/hosts/vps/cfg.nix
+++ b/hosts/vps/cfg.nix
@@ -5,30 +5,22 @@
     ../../profiles/ssh.nix
     ../../mixins/tailscale.nix
     ../../mixins/cli.nix
-    (modulesPath + "/profiles/qemu-guest.nix")
   ];
 
   config = {
     _module.args.nixinate = {
-      host = "95.179.249.76";
+      host = "100.67.217.90";
       sshUser = "nixos";
       buildOn = "remote"; # valid args are "local" or "remote"
       substituteOnTarget = true; # if buildOn is "local" then it will substitute on the target, "-s"
       hermetic = false;
     };
 
-    disko.devices = import ../disko.nix {
-      lib = pkgs.lib;
-    };
     networking.hostName = "vps";
     
     boot = {
-      initrd = {
-        supportedFilesystems = ["btrfs"];
-      };
       kernelPackages = lib.mkDefault pkgs.linuxPackages_latest;
       kernelParams = [
-        "console=ttyS0"
         "init_on_free=1"
         "page_poison=1"
         "page_alloc.shuffle=1"
@@ -36,17 +28,21 @@
         "vsyscall=none"
       ];
       cleanTmpDir = true;
-      loader = {
-        systemd-boot = {
-          enable = true;
-        };
-        efi = {
-          canTouchEfiVariables = true;
-          efiSysMountPoint = "/boot";
-        };
+      loader.grub.device = "/dev/vda";
+      initrd = {
+        availableKernelModules = [ "ata_piix" "uhci_hcd" "virtio_pci" "sr_mod" "virtio_blk" ];
+        kernelModules = [];
       };
+      kernelModules = [];
+      extraModulePackages = [];
     };
 
+    networking.interfaces.ens3.useDHCP = lib.mkDefault true;
+
+    nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+    hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+    virtualisation.hypervGuest.enable = true;
+
     time.timeZone = lib.mkDefault "Frankfurt";
 
     fileSystems = {
@@ -56,14 +52,17 @@
         options = ["noexec" "defaults" "size=2G" "mode=755"];
       };
       "/nix" = {
-        device = "/dev/disk/by-partlabel/nix";
-        options = ["noatime" "compress=zstd"];
+        device = "/dev/disk/by-uuid/e4c4735d-bfdd-477f-bc43-d07510cb6a9a";
+        fsType = "btrfs";
       };
       "/boot" = {
-        device = "/dev/disk/by-partlabel/boot";
+        device = "/dev/disk/by-uuid/7ea63707-099d-4c21-90eb-a51bfa6d8ba5";
+        fsType = "ext4";
       };
     };
 
+    swapDevices = [ { device = "/dev/disk/by-uuid/00eb2d2e-4d7c-4e95-804d-e9ecb22679d4"; } ];
+
     zramSwap = {
       enable = true;
       algorithm = "zstd";