summary refs log tree commit diff
path: root/hosts/vm/cfg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/vm/cfg.nix')
-rw-r--r--hosts/vm/cfg.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/hosts/vm/cfg.nix b/hosts/vm/cfg.nix
index 7f822b0..5c47612 100644
--- a/hosts/vm/cfg.nix
+++ b/hosts/vm/cfg.nix
@@ -13,6 +13,7 @@
     ../../mixins/tailscale.nix
     ../../mixins/cli.nix
     ../../mixins/greet.nix
+    ../../mixins/pipewire.nix
     # ../../mixins/hyprland.nix
     ../../mixins/sway.nix
     # (modulesPath + "/profiles/qemu-guest.nix")
@@ -81,13 +82,17 @@
       algorithm = "zstd";
     };
 
-    greeter.initialSession = "sh -c ${pkgs.sway}/bin/sway";
-
     hardware.opengl = {
       enable = true;
       extraPackages = with pkgs; [ rocm-opencl-icd rocm-opencl-runtime ];
       driSupport = true;
       driSupport32Bit = true;
     };
+
+    greeter.initialSession = "env WLR_RENDERER=pixman ${pkgs.sway.out}/bin/sway";
+    # home-manager.users.tzlil.wayland.windowManager.sway.config.input."type:keyboard".xkb_variant = lib.mkForce "";
+ 
+    # nice to work with
+    security.sudo.wheelNeedsPassword = false; 
   };
 }