summary refs log tree commit diff
path: root/hosts/vm/cfg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/vm/cfg.nix')
-rw-r--r--hosts/vm/cfg.nix16
1 files changed, 11 insertions, 5 deletions
diff --git a/hosts/vm/cfg.nix b/hosts/vm/cfg.nix
index 8efee3b..3b5ace8 100644
--- a/hosts/vm/cfg.nix
+++ b/hosts/vm/cfg.nix
@@ -11,7 +11,18 @@
   ];
 
   config = {
+    _module.args.nixinate = {
+      host = "100.109.155.123";
+      sshUser = "tzlil";
+      buildOn = "remote"; # valid args are "local" or "remote"
+      substituteOnTarget = true; # if buildOn is "local" then it will substitute on the target, "-s"
+      hermetic = false;
+    };
     networking.hostName = "vm";
+
+    # dont do this
+    users.users.root.initialPassword = "hunter2";
+    
     boot.supportedFilesystems = ["9p"];
     boot = {
       initrd = {
@@ -53,11 +64,6 @@
       "/boot" = {
         device = "/dev/disk/by-partlabel/boot";
       };
-      "/flake" = {
-        fsType = "9p";
-        device = "host0";
-        options = ["_netdev"];
-      };
     };
 
     zramSwap = {