summary refs log tree commit diff
path: root/mixins/sway.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2024-04-19 18:02:16 +0300
committertzlil <tzlils@protonmail.com>2024-04-19 18:02:16 +0300
commitf6998f6492693a2c53eaf5e4be9cd65cb36d6128 (patch)
tree235bb4d4e73218cc50ac503fbd65c9d939b93efd /mixins/sway.nix
parentff3f8bf2ed6a4d5f5169ec1925db9d1e0a14568c (diff)
updated flake and added window switcher HEAD master
Diffstat (limited to 'mixins/sway.nix')
-rw-r--r--mixins/sway.nix25
1 files changed, 22 insertions, 3 deletions
diff --git a/mixins/sway.nix b/mixins/sway.nix
index a3eaf4b..9c452b5 100644
--- a/mixins/sway.nix
+++ b/mixins/sway.nix
@@ -11,7 +11,7 @@
         enable = true;
         settings = {
           mainBar = {
-            modules-left = ["sway/workspaces" "sway/mode" "wlr/taskbar"];
+            modules-left = ["sway/workspaces" "sway/mode"];
             modules-center = ["sway/window"];
             modules-right = ["mpd" "temperature" "battery" "clock"];
 
@@ -22,6 +22,24 @@
           };
         };
       };
+
+      programs.swayr = {
+        enable = true;
+        settings = {
+          menu = {
+            executable = "${lib.getExe pkgs.kickoff}";
+            args = [
+              "-p={prompt}"
+              "--from-stdin"
+              "--stdout"
+            ];
+
+            # dont even fucking ask
+          };
+          format.window_format = "{app_name} - {title} on workspace {workspace_name} = #s:[con_id={id}] focuss";
+        };
+	systemd.enable = true;
+      };
       services.mako.enable = true;
       home.packages = with pkgs; [
         wf-recorder
@@ -95,9 +113,9 @@
         wrapperFeatures.gtk = true;
         config = rec {
           fonts = {
-            names = ["Iosevka"];
+            names = ["APL385 Unicode"];
             style = "Regular";
-            size = 11.0;
+            size = 14.0;
           };
           output = {
             "DP-1" = {
@@ -137,6 +155,7 @@
             "${modifier}+Return" = "exec $term";
             "${modifier}+q" = "kill";
             "${modifier}+d" = "exec ${lib.getExe pkgs.kickoff}";
+            "${modifier}+r" = "exec ${lib.getExe pkgs.swayr} switch-window";
             "${modifier}+Shift+c" = "reload";
             "${modifier}+Shift+q" = "exec swaynag -t warning -m 'you sure?' -B 'yes' 'swaymsg exit' -s 'no'";
             "${modifier}+Shift+p" = "exec systemctl poweroff";