summary refs log tree commit diff
path: root/mixins/sway.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-10-20 11:34:30 +0300
committertzlil <tzlils@protonmail.com>2023-10-20 11:34:30 +0300
commit00db7aca343a925220b17223b02dfb79b05f597c (patch)
treec4d578c37aec06001ec52c9494339eb62418bbf4 /mixins/sway.nix
parent313b15f10fee61500de8b8b1333702da8375f6b6 (diff)
stuff
Diffstat (limited to 'mixins/sway.nix')
-rw-r--r--mixins/sway.nix69
1 files changed, 21 insertions, 48 deletions
diff --git a/mixins/sway.nix b/mixins/sway.nix
index e588531..5981049 100644
--- a/mixins/sway.nix
+++ b/mixins/sway.nix
@@ -25,51 +25,21 @@ in {
   config = {
     security.pam.services.swaylock = {};
     home-manager.users.tzlil = {
-      xdg.configFile."i3status-rust/config.toml".text = ''
-        [icons]
-        icons = "awesome6"
-
-        [theme]
-        theme = "semi-native"
-        [theme.overrides]
-        separator = ""
-
-        [[block]]
-        block = "music"
-        [[block.click]]
-        action = "play_pause"
-        button = "left"
-
-        [[block]]
-        block = "net"
-        format = " $icon {$ssid |}$ip "
-        [[block]]
-        block = "memory"
-        format = " $icon $mem_total_used_percents.eng(w:2) "
-
-        [[block]]
-        block = "cpu"
-
-        [[block]]
-        block = "load"
-
-        [[block]]
-        block = "battery"
-        interval = 10
-        #format = "$percentage $time"
-
-        [[block]]
-        block = "sound"
-        headphones_indicator=true
-        [[block.click]]
-        cmd = "${lib.getExe pkgs.pavucontrol}"
-        button = "left"
-
-        [[block]]
-        block = "time"
-        interval = 60
-        format = "$icon $timestamp.datetime(f:'%a %Y-%m-%d %H:%M')"
-      '';
+      programs.waybar = {
+        enable = true;
+        settings = {
+          mainBar = {
+            modules-left = ["sway/workspaces" "sway/mode" "wlr/taskbar"];
+            modules-center = ["sway/window"];
+            modules-right = ["mpd" "temperature" "battery" "clock"];
+
+            "sway/workspaces" = {
+              disable-scroll = true;
+              all-outputs = false;
+            };
+          };
+        };
+      };
       services.mako.enable = true;
       home.packages = with pkgs; [
         wf-recorder
@@ -155,12 +125,15 @@ in {
           bars = [
             {
               fonts = {
-                names = ["Iosevka" "FontAwesome"];
+                # names = ["Iosevka" "FontAwesome"];
+                names = ["APL385 Unicode"];
                 style = "Regular";
-                size = 11.0;
+                size = 14.0;
               };
               position = "top";
-              statusCommand = "${pkgs.i3status-rust}/bin/i3status-rs";
+              # statusCommand = "${pkgs.i3status-rust}/bin/i3status-rs";
+              command = "${lib.getExe pkgs.waybar}";
+              # command = "waybar";
               colors = {
                 statusline = "#ffffff";
                 background = "#323232";