summary refs log tree commit diff
path: root/mixins/pipewire.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2022-12-13 15:21:30 +0200
committertzlil <tzlils@protonmail.com>2022-12-13 15:21:30 +0200
commitf51f8e398fffe33dcbb4b9f9db95708e7a3dde82 (patch)
tree08a9c853a29b01c53be526aecc8d2505f5086af5 /mixins/pipewire.nix
parent24637dfdfdd6dc8d116542f16a07d808c9e43c36 (diff)
stuff
Diffstat (limited to 'mixins/pipewire.nix')
-rw-r--r--mixins/pipewire.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/mixins/pipewire.nix b/mixins/pipewire.nix
new file mode 100644
index 0000000..7f17aa1
--- /dev/null
+++ b/mixins/pipewire.nix
@@ -0,0 +1,15 @@
+{ pkgs, config, ... }:
+
+{
+  config = {
+    sound.enable = false;
+    security.rtkit.enable = true;
+    services.pipewire = {
+      enable = true;
+      alsa.enable = true;
+      alsa.support32Bit = true;
+      pulse.enable = true;
+      jack.enable = true;
+    };
+  };
+}
\ No newline at end of file