summary refs log tree commit diff
path: root/mixins/multimedia.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-03-24 14:11:12 +0300
committertzlil <tzlils@protonmail.com>2023-03-24 14:11:12 +0300
commitf93700b22836af7e92108c697f4638bca433b87e (patch)
treee92d78dfb6ff2fd3b401acc2f3e1cc26af49fd0b /mixins/multimedia.nix
parent2e917bc65bba94a9b4b4eaddb90db2824e869ac9 (diff)
work on laptop
Diffstat (limited to 'mixins/multimedia.nix')
-rw-r--r--mixins/multimedia.nix34
1 files changed, 30 insertions, 4 deletions
diff --git a/mixins/multimedia.nix b/mixins/multimedia.nix
index d36be17..9d5c4b2 100644
--- a/mixins/multimedia.nix
+++ b/mixins/multimedia.nix
@@ -6,16 +6,42 @@
   ...
 }: {
   config = {
-    home-manager.users.tzlil = {...}: {
+    home-manager.users.tzlil = {config, ...}: {
       fonts.fontconfig.enable = true;
-
       home.packages = with pkgs; [
-        mpv
-        zathura
         ffmpeg
         gimp
         transmission
+        xdg-utils
+        xdg-user-dirs
       ];
+      xdg = {
+        enable = true;
+        mime.enable = true;
+        mimeApps = {
+          enable = true;
+          defaultApplications = {
+            "application/pdf" = ["${pkgs.zathura}/share/applications/org.pwmt.zathura.desktop"];
+          };
+        };
+        userDirs = {
+          createDirectories = true;
+          desktop = "${config.home.homeDirectory}/desktop";
+          download = "${config.home.homeDirectory}/downloads";
+        };
+      };
+
+      programs = {
+        mpv = {
+          enable = true;
+          scripts = [
+            pkgs.mpvScripts.mpris
+          ];
+        };
+        zathura = {
+          enable = true;
+        };
+      };
     };
   };
 }