summary refs log tree commit diff
path: root/mixins/greet.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-03-24 14:11:12 +0300
committertzlil <tzlils@protonmail.com>2023-03-24 14:11:12 +0300
commitf93700b22836af7e92108c697f4638bca433b87e (patch)
treee92d78dfb6ff2fd3b401acc2f3e1cc26af49fd0b /mixins/greet.nix
parent2e917bc65bba94a9b4b4eaddb90db2824e869ac9 (diff)
work on laptop
Diffstat (limited to 'mixins/greet.nix')
-rw-r--r--mixins/greet.nix26
1 files changed, 17 insertions, 9 deletions
diff --git a/mixins/greet.nix b/mixins/greet.nix
index 103b37a..794d322 100644
--- a/mixins/greet.nix
+++ b/mixins/greet.nix
@@ -10,25 +10,33 @@
   greet = "${pkgs.greetd.gtkgreet.out}/bin/gtkgreet -l -s ${pkgs.writeText "gtkgreet.css" "
 window {
   background-image: url(\"${pkgs.fetchurl {
-    url = "https://external-content.duckduckgo.com/iu/?u=https%3A%2F%2Fget.wallhere.com%2Fphoto%2FSerial-Experiments-Lain-anime-1363057.jpg&f=1&nofb=1&ipt=ba4bec61767537f6da6f0298f40e6a8ff2a5f1dc0e075a40bf77ba3a98654e15&ipo=images";
-    sha256 = "sha256-oFUfNBdodHP7p/tAlwttzsY2SIyfsEgya6sN2GXEGy8=";
+    url = "https://i.imgur.com/D6qCaQG.png";
+    sha256 = "sha256-Yt5JxmqN6++76cWu8EI/gsmelsJT/3jvLxyeRASQUhI=";
   }}\");
   background-size: cover;
   background-position: center;
+  color: white;
 }
 
 box#body {
-  background-color: rgba(50, 50, 50, 0.5);
-  border-radius: 10px;
+  background-color: rgba(50, 50, 50, 0.8);
+  border-radius: 40px;
   padding: 50px;
 }
+
+# log in text
+.text-button {
+  color: white;
+}
+
+
 "}";
 
   kiosk = command: "${pkgs.cage.out}/bin/cage -- ${command}";
 in {
   options.greeter.initialSession = lib.mkOption {
     type = lib.types.str;
-    default = "sh -c ${pkgs.sway}/bin/sway";
+    default = "${pkgs.sway.out}/bin/sway";
   };
 
   config = {
@@ -43,10 +51,10 @@ in {
           inherit user;
           command = kiosk "${greet} -l &>/dev/null";
         };
-        # initial_session = {
-        #   inherit user;
-        #   command = config.greeter.initialSession;
-        # };
+        initial_session = {
+          inherit user;
+          command = config.greeter.initialSession;
+        };
       };
     };
   };