summary refs log tree commit diff
path: root/mixins/greet.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-03-12 21:23:01 +0200
committertzlil <tzlils@protonmail.com>2023-03-12 21:23:01 +0200
commite94d2c69ff5ae50cc7a5ddc2598d7caef68e406f (patch)
tree205fd97e03d9bd446401446bf0fec9552ed7d7da /mixins/greet.nix
parent39eb0b807403c7745c2edc6024e0e713155662bc (diff)
bad commit
Diffstat (limited to 'mixins/greet.nix')
-rw-r--r--mixins/greet.nix17
1 files changed, 7 insertions, 10 deletions
diff --git a/mixins/greet.nix b/mixins/greet.nix
index fc1d151..fe2c825 100644
--- a/mixins/greet.nix
+++ b/mixins/greet.nix
@@ -7,12 +7,9 @@
   user = "tzlil";
 
   users.users.greeter.packages = [pkgs.sway];
-  greet = "${pkgs.greetd.wlgreet}/bin/wlgreet";
+  greet = "${pkgs.greetd.gtkgreet.out}/bin/gtkgreet";
 
-  sway-kiosk = command: "env WLR_RENDERER=pixman ${pkgs.sway}/bin/sway --unsupported-gpu --config ${pkgs.writeText "kiosk.config" ''
-    output * bg #000000 solid_color
-    exec "${command}; ${pkgs.sway}/bin/swaymsg exit"
-  ''}";
+  kiosk = command: "${pkgs.cage.out}/bin/cage -- ${command}";
 in {
   options.greeter.initialSession = lib.mkOption {
     type = lib.types.str;
@@ -29,12 +26,12 @@ in {
       settings = {
         default_session = {
           inherit user;
-          command = sway-kiosk "${greet} -l &>/dev/null";
-        };
-        initial_session = {
-          inherit user;
-          command = config.greeter.initialSession;
+          command = kiosk "${greet} -l &>/dev/null";
         };
+        # initial_session = {
+        #   inherit user;
+        #   command = config.greeter.initialSession;
+        # };
       };
     };
   };