summary refs log tree commit diff
path: root/mixins/firefox/default.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-08-02 05:06:08 +0300
committertzlil <tzlils@protonmail.com>2023-08-02 05:06:08 +0300
commit3133f6144852987da706cc988743355dbf1bb0dd (patch)
tree27cb363d7d36f6e3af083f06a408ff70a93de06f /mixins/firefox/default.nix
parent09ef721663c7ead400f47880a6aa18f7920f6c34 (diff)
browser notes
Diffstat (limited to 'mixins/firefox/default.nix')
-rw-r--r--mixins/firefox/default.nix36
1 files changed, 22 insertions, 14 deletions
diff --git a/mixins/firefox/default.nix b/mixins/firefox/default.nix
index 42bc634..3ab8795 100644
--- a/mixins/firefox/default.nix
+++ b/mixins/firefox/default.nix
@@ -8,6 +8,14 @@ in
     ...
   }: {
     home-manager.users.tzlil = {
+      /*
+      TODO
+      figure out if you like sidebery or TST more
+      if sidebery: figure out where options are stored so you can set colors declaratively and also tree groups
+      also figure out how to make ctrl+e for SB not conflict with vimium, maybe will rebind to F1
+      figure out the search engine crap, i have them hidden but id like them removed completely, Extensions.Uninstall and SearchEngines.Remove did nothing
+      incorporate user.js instead of hardcoding some shit myself
+      */
       home.file.".mozilla/firefox/default/browser-extension-data/redirector@einaregilsson.com/storage.js".text = builtins.toJSON {
         redirects =
           map ({
@@ -49,21 +57,21 @@ in
             OverrideFirstRunPage = "";
             Extensions = {
               Install = map (x: x.src.outPath) config.home-manager.users.tzlil.programs.firefox.profiles."default".extensions;
-              Uninstall = [
-                "google@search.mozilla.org"
-                "amazondotcom@search.mozilla.org"
-                "wikipedia@search.mozilla.org"
-                "bing@search.mozilla.org"
-              ];
+              # Uninstall = [
+              #   "google@search.mozilla.org"
+              #   "amazondotcom@search.mozilla.org"
+              #   "wikipedia@search.mozilla.org"
+              #   "bing@search.mozilla.org"
+              # ];
             };
-            SearchEngines.Remove = [
-              "Amazon"
-              "Bing"
-              "Google"
-              "Twitter"
-              "Wikipedia"
-              "Yahoo"
-            ];
+            # SearchEngines.Remove = [
+            #   "Amazon"
+            #   "Bing"
+            #   "Google"
+            #   "Twitter"
+            #   "Wikipedia"
+            #   "Yahoo"
+            # ];
           };
         };
         profiles."${profile}" = {