summary refs log tree commit diff
path: root/mixins/cli.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-02-16 16:40:26 +0200
committertzlil <tzlils@protonmail.com>2023-02-16 16:40:26 +0200
commitd4896b353eed0ab37cf8a2591fe1f5369c37883f (patch)
tree267fcc685ce9efa2db60e51c772ef58ccfe6d330 /mixins/cli.nix
parent566dc1e8f6e619f590f017a810a8a55d9a90a25c (diff)
stuff
Diffstat (limited to 'mixins/cli.nix')
-rw-r--r--mixins/cli.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/mixins/cli.nix b/mixins/cli.nix
index 61153d3..0d82ed1 100644
--- a/mixins/cli.nix
+++ b/mixins/cli.nix
@@ -15,6 +15,8 @@
           rsync
           curl
           ripgrep
+          bat
+          croc
         ];
       };
       programs = {
@@ -24,11 +26,16 @@
           userEmail = "tzlils@protonmail.com";
           enable = true;
         };
+        direnv = {
+          enable = true;
+          nix-direnv.enable = true;
+        };
         fish = {
           enable = true;
           shellAliases = {
             gc = "git clone";
             l = "ls -alh";
+            b = "bat";
           };
           functions = {
             sb.body = "nixos-rebuild build --flake git+ssh://pc/home/tzlil/newflake --use-remote-sudo";