summary refs log tree commit diff
path: root/mixins/cli.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-09-09 01:47:07 +0300
committertzlil <tzlils@protonmail.com>2023-09-09 01:48:16 +0300
commitb8d9878cea5a65e2e6ab4b98aace676f34038824 (patch)
tree97b54439395f9c9eea0f9940ba6285ca836252e5 /mixins/cli.nix
parent387836d53360039514bfa11014e48687dd82ed2d (diff)
add arxiv randomizer and some other crap i forgot
Diffstat (limited to 'mixins/cli.nix')
-rw-r--r--mixins/cli.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/mixins/cli.nix b/mixins/cli.nix
index ceb485b..ab01eb4 100644
--- a/mixins/cli.nix
+++ b/mixins/cli.nix
@@ -17,6 +17,7 @@
           curl
           ripgrep
           bat
+          jq
 
           # p2p file transfer
           croc
@@ -73,6 +74,7 @@
             gs = "git status";
             l = "ls -alh";
             b = "bat";
+            alv = "ping -c 1 -W 1";
           };
           functions = {
             fish_greeting = "";
@@ -86,6 +88,7 @@
             nr = "nix run nixpkgs#$argv[1] $argv[2..]";
             tmp = "cd (mktemp -d --suffix -$argv[1])";
             py = ''python -c "print(eval(\"\"\"$argv\"\"\"))"'';
+
             # fish_command_not_found = "nix shell nixpkgs#(command-not-found $argv[1] &| sed -nr 's/.*-p (.*)$/\\1/p' | ${lib.getExe pkgs.fzf} || return 0) -c $argv[1]";
           };
         };