summary refs log tree commit diff
path: root/mixins/cli.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-02-26 01:00:28 +0200
committertzlil <tzlils@protonmail.com>2023-02-26 01:00:28 +0200
commit6c83265b0a6ff3682ff6f8d65946282da5abac4c (patch)
treee49cdacb338814f81fbf83d3f5a1462c107e82ae /mixins/cli.nix
parentfa27bb3e6f6ccbc548303b5f259c1020450fef6e (diff)
remove gpg agent stuff, remove fish greeting
Diffstat (limited to 'mixins/cli.nix')
-rw-r--r--mixins/cli.nix39
1 files changed, 37 insertions, 2 deletions
diff --git a/mixins/cli.nix b/mixins/cli.nix
index 9ce9ee4..abf40e0 100644
--- a/mixins/cli.nix
+++ b/mixins/cli.nix
@@ -9,7 +9,12 @@
     inputs.home-manager.nixosModules."home-manager"
   ];
   config = {
-    home-manager.users.tzlil = {pkgs, ...} @ hm: {
+    home-manager.users.tzlil = {
+      pkgs,
+      config,
+      nixosConfig,
+      ...
+    } @ hm: {
       home = {
         packages = with pkgs; [
           rsync
@@ -21,7 +26,6 @@
         sessionVariables.EDITOR = "nvim";
       };
       programs = {
-        ssh.enable = true;
         git = {
           userName = "tzlil";
           userEmail = "tzlils@protonmail.com";
@@ -41,6 +45,7 @@
           functions = {
             sb.body = "nixos-rebuild build --flake git+ssh://pc/home/tzlil/newflake --use-remote-sudo";
             sw.body = "nixos-rebuild switch --flake git+ssh://pc/home/tzlil/newflake --use-remote-sudo";
+            fish_greeting.body = "";
           };
         };
         neovim = {
@@ -48,7 +53,37 @@
           viAlias = true;
           vimAlias = true;
         };
+        # gpg = {
+        #   enable = true;
+        #   mutableKeys = false;
+        #   mutableTrust = false;
+        #   settings = {
+        #     default-key = "E989 C39F 5AE8 2790 F41E  AD50 5FEF 5315 1562 A6CD";
+        #     default-recipient-self = true;
+        #     auto-key-locate = "local,wkd,keyserver";
+        #     keyserver = "hkps://keys.openpgp.org";
+        #     auto-key-retrieve = true;
+        #     auto-key-import = true;
+        #     keyserver-options = "honor-keyserver-url";
+        #     no-autostart = true;
+        #   };
+        # };
       };
+      # services.gpg-agent = let
+      #   m = 60;
+      #   h = 60 * m;
+      #   d = 24 * h;
+      #   y = 365 * d;
+      # in {
+      #   enable = true;
+      #   enableSshSupport = true;
+      #   enableFishIntegration = true;
+      #   defaultCacheTtl = 6 * h;
+      #   defaultCacheTtlSsh = 6 * h;
+      #   maxCacheTtl = 100 * y; # effectively unlimited
+      #   maxCacheTtlSsh = 100 * y; # effectively unlimited
+      #   sshKeys = ["E989C39F5AE82790F41EAD505FEF53151562A6CD"];
+      # };
     };
   };
 }