summary refs log tree commit diff
path: root/mixins/cli.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-08-12 22:36:08 +0300
committertzlil <tzlils@protonmail.com>2023-08-12 22:36:08 +0300
commit61a06724bc39e94da259efba3693857bae21949f (patch)
tree37474f635cd12b182ef60e05ffa994275d568e96 /mixins/cli.nix
parent551351a9d6661ffb0ad1fea46017714f04a3a70c (diff)
add pragmata and py and uhhhhh
Diffstat (limited to 'mixins/cli.nix')
-rw-r--r--mixins/cli.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/mixins/cli.nix b/mixins/cli.nix
index 6c784eb..abc2650 100644
--- a/mixins/cli.nix
+++ b/mixins/cli.nix
@@ -17,8 +17,12 @@
           curl
           ripgrep
           bat
+
+          # p2p file transfer
           croc
 
+          nix-output-monitor
+
           # crap i need in my shell for general usage, mostly data science
           (pkgs.python3.withPackages (ps:
             with ps; [
@@ -66,6 +70,7 @@
           enable = true;
           shellAliases = {
             gc = "git clone";
+            gs = "git status";
             l = "ls -alh";
             b = "bat";
           };
@@ -78,6 +83,8 @@
               end
               nix shell $p
             '';
+            tmp = "cd (mktemp -d --suffix -$argv[1])";
+            py = ''python -c "print(eval(\"\"\"$argv\"\"\"))"'';
             # fish_command_not_found = "nix shell nixpkgs#(command-not-found $argv[1] &| sed -nr 's/.*-p (.*)$/\\1/p' | ${lib.getExe pkgs.fzf} || return 0) -c $argv[1]";
           };
         };