summary refs log tree commit diff
path: root/mixins/cli.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-07-13 15:59:10 +0300
committertzlil <tzlils@protonmail.com>2023-07-13 15:59:10 +0300
commit5d01fd8493a120fc714e9adaf758367340e57526 (patch)
tree14e6cb87594675a083817a6321a090eac792232d /mixins/cli.nix
parent36b0692fb7dca966aba42fa093aab84913432ba8 (diff)
make ns function actually work
Diffstat (limited to 'mixins/cli.nix')
-rw-r--r--mixins/cli.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/mixins/cli.nix b/mixins/cli.nix
index 14417b0..5ef2cfe 100644
--- a/mixins/cli.nix
+++ b/mixins/cli.nix
@@ -78,7 +78,13 @@
           };
           functions = {
             fish_greeting = "";
-            ns = "eval nix shell nixpkgs#\\{(string join \",\" $argv)\\}";
+            ns = ''
+	    set -l p
+	    for a in $argv
+	    	set p $p "nixpkgs#$a"
+	    end
+	    nix shell $p
+	    '';
           };
         };
         neovim = {