summary refs log tree commit diff
path: root/hosts/vps/hardware-configuration.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-07-30 18:25:45 +0300
committertzlil <tzlils@protonmail.com>2023-07-30 18:25:45 +0300
commit6f4af85daec2e1db5be2668d15b5f851b436a35b (patch)
tree9082bc2971d50d60f7debbb44dbf6b23bb753c52 /hosts/vps/hardware-configuration.nix
parentf72f22b250ecf22657ffc9e6082086377031ea8a (diff)
uhhhh
Diffstat (limited to 'hosts/vps/hardware-configuration.nix')
-rw-r--r--hosts/vps/hardware-configuration.nix44
1 files changed, 21 insertions, 23 deletions
diff --git a/hosts/vps/hardware-configuration.nix b/hosts/vps/hardware-configuration.nix
index 2d9a5fa..a39dc64 100644
--- a/hosts/vps/hardware-configuration.nix
+++ b/hosts/vps/hardware-configuration.nix
@@ -5,32 +5,30 @@
   config,
   ...
 }: {
-     fileSystems = {
-      "/" = {
-        device = "none";
-        fsType = "tmpfs";
-        options = ["noexec" "defaults" "size=2G" "mode=755"];
-      };
-      "/nix" = {
-        device = "/dev/disk/by-uuid/e4c4735d-bfdd-477f-bc43-d07510cb6a9a";
-        fsType = "btrfs";
-      };
-      "/boot" = {
-        device = "/dev/disk/by-uuid/7ea63707-099d-4c21-90eb-a51bfa6d8ba5";
-        fsType = "ext4";
-      };
+  fileSystems = {
+    "/" = {
+      device = "none";
+      fsType = "tmpfs";
+      options = ["noexec" "defaults" "size=2G" "mode=755"];
     };
-
-    swapDevices = [{device = "/dev/disk/by-uuid/00eb2d2e-4d7c-4e95-804d-e9ecb22679d4";}];
-
-    zramSwap = {
-      enable = true;
-      algorithm = "zstd";
+    "/nix" = {
+      device = "/dev/disk/by-uuid/e4c4735d-bfdd-477f-bc43-d07510cb6a9a";
+      fsType = "btrfs";
+    };
+    "/boot" = {
+      device = "/dev/disk/by-uuid/7ea63707-099d-4c21-90eb-a51bfa6d8ba5";
+      fsType = "ext4";
     };
+  };
 
+  swapDevices = [{device = "/dev/disk/by-uuid/00eb2d2e-4d7c-4e95-804d-e9ecb22679d4";}];
 
-    nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
-    hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
-    virtualisation.hypervGuest.enable = true;
+  zramSwap = {
+    enable = true;
+    algorithm = "zstd";
+  };
 
+  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+  hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+  virtualisation.hypervGuest.enable = true;
 }