summary refs log tree commit diff
path: root/hosts/pc/default.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-07-29 20:53:14 +0300
committertzlil <tzlils@protonmail.com>2023-07-29 20:53:14 +0300
commitfeefcfc89b00d4955dbb3314c20be035f3db206f (patch)
tree5099a13763dcfd274cae83af4dbac0bf4bef6cce /hosts/pc/default.nix
parent11526bdd2bb3b4b445665aa671e4bc72021b8183 (diff)
disko for laptop, wip rewrite
Diffstat (limited to 'hosts/pc/default.nix')
-rw-r--r--hosts/pc/default.nix87
1 files changed, 87 insertions, 0 deletions
diff --git a/hosts/pc/default.nix b/hosts/pc/default.nix
new file mode 100644
index 0000000..ee3b716
--- /dev/null
+++ b/hosts/pc/default.nix
@@ -0,0 +1,87 @@
+{
+  config,
+  lib,
+  pkgs,
+  ...
+}: {
+  imports = [
+    ../../profiles/core.nix
+    ../../profiles/user.nix
+    ../../profiles/ssh.nix
+    ../../profiles/graphical.nix
+    ../../mixins/tailscale.nix
+    ../../mixins/cli.nix
+    ../../mixins/greet.nix
+    # ../../mixins/hyprland.nix
+    ../../mixins/sway.nix
+  ];
+
+  config = {
+    _module.args.nixinate = {
+      host = "pc";
+      sshUser = "tzlil";
+      buildOn = "remote"; # valid args are "local" or "remote"
+      substituteOnTarget = true; # if buildOn is "local" then it will substitute on the target, "-s"
+      hermetic = false;
+    };
+    networking.hostName = "pc";
+
+    boot = {
+      initrd = {
+        supportedFilesystems = ["btrfs"];
+        availableKernelModules = ["xhci_pci" "ahci" "nvme" "usbhid"];
+      };
+      kernelModules = ["kvm-amd"];
+      kernelPackages = lib.mkDefault pkgs.linuxPackages_latest;
+      loader = {
+        systemd-boot = {
+          enable = true;
+        };
+        efi = {
+          canTouchEfiVariables = true;
+          efiSysMountPoint = "/boot";
+        };
+      };
+    };
+
+    time.timeZone = lib.mkDefault "Israel";
+
+    fileSystems = {
+      "/" = {
+        device = "/dev/disk/by-uuid/3fe7d38b-bb95-41ca-afce-1b0b89cbcd8b";
+        fsType = "btrfs";
+        options = ["subvol=root"];
+      };
+
+      "/nix" = {
+        device = "/dev/disk/by-uuid/3fe7d38b-bb95-41ca-afce-1b0b89cbcd8b";
+        fsType = "btrfs";
+        options = ["subvol=nix"];
+      };
+
+      "/home" = {
+        device = "/dev/disk/by-uuid/3fe7d38b-bb95-41ca-afce-1b0b89cbcd8b";
+        fsType = "btrfs";
+        options = ["subvol=home"];
+      };
+
+      "/swap" = {
+        device = "/dev/disk/by-uuid/3fe7d38b-bb95-41ca-afce-1b0b89cbcd8b";
+        fsType = "btrfs";
+        options = ["subvol=swap"];
+      };
+      "/boot" = {
+        device = "/dev/disk/by-uuid/D999-2D99";
+        fsType = "vfat";
+      };
+    };
+
+    zramSwap = {
+      enable = true;
+      algorithm = "zstd";
+    };
+
+    hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+    # greeter.initialSession = "sh -c hyprland";
+  };
+}