summary refs log tree commit diff
path: root/hosts/navi/hardware-configuration.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-08-03 21:37:04 +0300
committertzlil <tzlils@protonmail.com>2023-08-03 21:37:04 +0300
commit73cd8a2ab81b91aaca8095c77de12ea39fbc2fed (patch)
tree898960c644e7ab2cb9191acd7dba2936fa8bab1b /hosts/navi/hardware-configuration.nix
parent77da12bae6fb23133758cd92ebd0d814a96ff46f (diff)
fix vm vm
Diffstat (limited to 'hosts/navi/hardware-configuration.nix')
-rw-r--r--hosts/navi/hardware-configuration.nix17
1 files changed, 11 insertions, 6 deletions
diff --git a/hosts/navi/hardware-configuration.nix b/hosts/navi/hardware-configuration.nix
index f556950..480f255 100644
--- a/hosts/navi/hardware-configuration.nix
+++ b/hosts/navi/hardware-configuration.nix
@@ -3,7 +3,7 @@
   pkgs,
   lib,
   config,
-  # modulesPath,
+  modulesPath,
   ...
 }: let
   device = "/dev/nvme0n1";
@@ -13,7 +13,7 @@ in {
     inputs.hardware.nixosModules.common-cpu-intel
     inputs.hardware.nixosModules.common-gpu-intel
 
-    # (modulesPath + "/virtualisation/qemu-vm.nix")
+    (modulesPath + "/virtualisation/qemu-vm.nix")
   ];
 
   hardware.firmware = [pkgs.rtw88-firmware];
@@ -26,6 +26,7 @@ in {
 
   hardware.bluetooth.enable = true;
 
+  fileSystems."/nix/persist".neededForBoot = true;
   disko.devices = {
     disk.${baseNameOf device} = {
       inherit device;
@@ -44,9 +45,9 @@ in {
           };
           root = {
             size = "100%";
-            content = {
-              type = "luks";
-              name = "cryptroot";
+            # content = {
+              # type = "luks";
+              # name = "cryptroot";
               content = {
                 type = "btrfs";
                 extraArgs = ["-f"];
@@ -55,9 +56,13 @@ in {
                     mountOptions = ["compress=zstd" "noatime"];
                     mountpoint = "/nix";
                   };
+                  "/nix/persist" = {
+                    mountOptions = ["compress=zstd" "noatime"];
+                    mountpoint = "/nix/persist";
+                  };
                 };
               };
-            };
+            # };
           };
         };
       };