summary refs log tree commit diff
path: root/hosts/laptop/cfg.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-03-12 16:29:17 +0200
committertzlil <tzlils@protonmail.com>2023-03-12 16:29:17 +0200
commit39eb0b807403c7745c2edc6024e0e713155662bc (patch)
tree7aca56baa092ecf5f58b6c2e4d597d613cca196b /hosts/laptop/cfg.nix
parentf266d1b0d7c2f9c5c285af539fefe8d5ac96c479 (diff)
bunch of stuff
Diffstat (limited to 'hosts/laptop/cfg.nix')
-rw-r--r--hosts/laptop/cfg.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/hosts/laptop/cfg.nix b/hosts/laptop/cfg.nix
index 32f60fe..f4befe8 100644
--- a/hosts/laptop/cfg.nix
+++ b/hosts/laptop/cfg.nix
@@ -11,13 +11,13 @@
     ../../profiles/graphical.nix
     ../../mixins/tailscale.nix
     ../../mixins/cli.nix
-    ../../mixins/greet.nix
-    ../../mixins/sway.nix
+    # ../../mixins/greet.nix
+    ../../mixins/hyprland.nix
   ];
 
   config = {
     _module.args.nixinate = {
-      host = "192.168.1.32";
+      host = "100.121.226.3";
       sshUser = "tzlil";
       buildOn = "remote"; # valid args are "local" or "remote"
       substituteOnTarget = true; # if buildOn is "local" then it will substitute on the target, "-s"
@@ -85,5 +85,7 @@
     nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
     powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
     hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+
+    # greeter.initialSession = "env WLR_RENDERER=pixman sh -c ${pkgs.sway}/bin/sway";
   };
 }