summary refs log tree commit diff
path: root/profiles/gentoo.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/gentoo.nix')
-rw-r--r--profiles/gentoo.nix37
1 files changed, 0 insertions, 37 deletions
diff --git a/profiles/gentoo.nix b/profiles/gentoo.nix
deleted file mode 100644
index 337a306..0000000
--- a/profiles/gentoo.nix
+++ /dev/null
@@ -1,37 +0,0 @@
-{
-  pkgs,
-  lib,
-  config,
-  inputs,
-  ...
-}: {
-  imports = [];
-  config = {
-    nix.binaryCaches = [
-      "https://cache.nixos.org/"
-      "https://cache.allvm.org/"
-    ];
-
-    nix.binaryCachePublicKeys = [
-      "gravity.cs.illinois.edu-1:yymmNS/WMf0iTj2NnD0nrVV8cBOXM9ivAkEdO1Lro3U="
-    ];
-
-    nativeStdenv =
-      prev.stdenvAdapters.withCFlags ["-O3" "-pipe" "-march=native"]
-      (prev.overrideCC prev.llvmPackages_latest.stdenv
-        (prev.wrapCCWith rec {
-          cc = prev.llvmPackages_latest.clang-unwrapped;
-          bintools = final.wrapBintoolsWith {
-            coreutils = final.uutils-coreutils;
-            libc = final.musl;
-            bintools =
-              final.binutils-unwrapped.overrideAttrs
-              (old: {
-                postInstall = ''
-                  ln -sf ${final.mold}/bin/mold $out/bin/ld
-                '';
-              });
-          };
-        }));
-  };
-}