summary refs log tree commit diff
path: root/profiles/core.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/core.nix')
-rw-r--r--profiles/core.nix43
1 files changed, 0 insertions, 43 deletions
diff --git a/profiles/core.nix b/profiles/core.nix
deleted file mode 100644
index 4fefbdd..0000000
--- a/profiles/core.nix
+++ /dev/null
@@ -1,43 +0,0 @@
-{
-  pkgs,
-  lib,
-  config,
-  inputs,
-  ...
-}: {
-  # imports = [
-  #   ../profiles/security.nix
-  #   ../profiles/network.nix
-  # ];
-  config = {
-    # system.stateVersion = "22.5";
-    # nix = {
-    #   registry.nixpkgs.flake = inputs.nixpkgs;
-    #   gc.automatic = true;
-    #   optimise.automatic = true;
-    #   settings = {
-    #     allowed-users = ["root"];
-    #     trusted-users = ["root"];
-    #     sandbox = true;
-    #   };
-    #   extraOptions = ''
-    #     experimental-features = nix-command flakes
-    #   '';
-    # };
-    # users.mutableUsers = false;
-    # environment.defaultPackages = lib.mkForce [];
-
-    programs.command-not-found.dbPath = inputs.programsdb.packages.${pkgs.system}.programs-sqlite;
-
-    # boot = {
-    #   tmp.cleanOnBoot = true;
-    #   kernelParams = [
-    #     "init_on_free=1"
-    #     "page_poison=1"
-    #     "page_alloc.shuffle=1"
-    #     "slab_nomerge"
-    #     "vsyscall=none"
-    #   ];
-    # };
-  };
-}