summary refs log tree commit diff
path: root/mixins/tailscale.nix
diff options
context:
space:
mode:
Diffstat (limited to 'mixins/tailscale.nix')
-rw-r--r--mixins/tailscale.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/mixins/tailscale.nix b/mixins/tailscale.nix
new file mode 100644
index 0000000..8be3147
--- /dev/null
+++ b/mixins/tailscale.nix
@@ -0,0 +1,11 @@
+{ pkgs, config, ... }:
+
+{
+  config = {
+    services.tailscale.enable = true;
+    networking.firewall = {
+      trustedInterfaces = [ "tailscale0" ];
+      allowedUDPPorts = [41641];
+    };
+  };
+}
\ No newline at end of file