summary refs log tree commit diff
path: root/mixins/firefox/schizo.nix
diff options
context:
space:
mode:
Diffstat (limited to 'mixins/firefox/schizo.nix')
-rw-r--r--mixins/firefox/schizo.nix80
1 files changed, 80 insertions, 0 deletions
diff --git a/mixins/firefox/schizo.nix b/mixins/firefox/schizo.nix
new file mode 100644
index 0000000..a85ae48
--- /dev/null
+++ b/mixins/firefox/schizo.nix
@@ -0,0 +1,80 @@
+{
+  pkgs,
+  lib,
+  config,
+  inputs,
+  ...
+}: {
+  home-manager.users.tzlil = {
+    imports = [
+      inputs.schizofox.homeManagerModule
+    ];
+    programs.schizofox = {
+      enable = true;
+      package = pkgs.firefox-wayland.unwrapped;
+      theme = {
+        background-darker = "181825";
+        background = "1e1e2e";
+        foreground = "cdd6f4";
+        font = "APL 385 Unicode";
+        simplefox.enable = true;
+        darkreader.enable = true;
+        extraCss = builtins.readFile ./userChrome.css;
+      };
+
+      search = {
+        defaultSearchEngine = "Kagi";
+        removeEngines = ["Google" "Bing" "Amazon.com" "eBay" "Twitter" "Wikipedia"];
+        addEngines = [
+          {
+            Name = "Kagi";
+            Description = "kagi";
+            Method = "GET";
+            URLTemplate = "https://kagi.com/search?q={searchTerms}";
+          }
+          {
+            Name = "nixpkgs";
+            Description = "nixpkgs";
+            Alias = "!np";
+            Method = "GET";
+            URLTemplate = "https://search.nixos.org/packages?type=packages&query={searchTerms}";
+          }
+          {
+            Name = "home-manager";
+            Description = "home-manager";
+            Alias = "!hm";
+            Method = "GET";
+            URLTemplate = "https://mipmip.github.io/home-manager-option-search?query={searchTerms}";
+          }
+          {
+            Name = "invidious";
+            Description = "invidious";
+            Alias = "!yt";
+            Method = "GET";
+            URLTemplate = "https://yewtu.be/search?q={searchTerms}";
+          }
+        ];
+      };
+
+      security = {
+        sanitizeOnShutdown = false;
+        sandbox = true;
+        userAgent = "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:106.0) Gecko/20100101 Firefox/106.0";
+      };
+
+      misc = {
+        # drmFix = true;
+        # disableWebgl = false;
+        startPageURL = "https://lobste.rs";
+      };
+
+      extensions.extraExtensions = {
+        "uBlock0@raymondhill.net".install_url = "https://addons.mozilla.org/firefox/downloads/file/4171020/ublock_origin-1.52.2.xpi";
+        "woop-NoopscooPsnSXQ@jetpack".install_url = "https://addons.mozilla.org/firefox/downloads/file/3360398/privacy_possum-2019.7.18.xpi";
+        "skipredirect@sblask".install_url = "https://addons.mozilla.org/firefox/downloads/file/3920533/skip_redirect-2.3.6.xpi";
+        "{3c078156-979c-498b-8990-85f7987dd929}".install_url = "https://github.com/mbnuqw/sidebery/releases/download/v5.0.0rc4/sidebery-5.0.0rc4.xpi";
+        "redirector@einaregilsson.com".install_url = "https://addons.mozilla.org/firefox/downloads/file/3535009/redirector-3.5.3.xpi";
+      };
+    };
+  };
+}