summary refs log tree commit diff
path: root/mixins/cli.nix
diff options
context:
space:
mode:
Diffstat (limited to 'mixins/cli.nix')
-rw-r--r--mixins/cli.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/mixins/cli.nix b/mixins/cli.nix
index abc2650..ceb485b 100644
--- a/mixins/cli.nix
+++ b/mixins/cli.nix
@@ -83,6 +83,7 @@
               end
               nix shell $p
             '';
+            nr = "nix run nixpkgs#$argv[1] $argv[2..]";
             tmp = "cd (mktemp -d --suffix -$argv[1])";
             py = ''python -c "print(eval(\"\"\"$argv\"\"\"))"'';
             # fish_command_not_found = "nix shell nixpkgs#(command-not-found $argv[1] &| sed -nr 's/.*-p (.*)$/\\1/p' | ${lib.getExe pkgs.fzf} || return 0) -c $argv[1]";