summary refs log tree commit diff
path: root/mixins/cli.nix
diff options
context:
space:
mode:
Diffstat (limited to 'mixins/cli.nix')
-rw-r--r--mixins/cli.nix20
1 files changed, 10 insertions, 10 deletions
diff --git a/mixins/cli.nix b/mixins/cli.nix
index 936098d..6c784eb 100644
--- a/mixins/cli.nix
+++ b/mixins/cli.nix
@@ -7,15 +7,10 @@
 }: {
   config = {
     home-manager.users.tzlil = {
-      pkgs,
-      config,
-      nixosConfig,
-      ...
-    }: {
       imports = [
         inputs.viper-nix-common.homeModules.xdg
+        inputs.nix-index-database.hmModules.nix-index
       ];
-      programs.command-not-found.dbPath = inputs.programsdb.packages.${pkgs.system}.programs-sqlite;
       home = {
         packages = with pkgs; [
           rsync
@@ -52,9 +47,6 @@
               ''
           )
         ];
-        #sessionVariables = {
-        #EDITOR = "nvim";
-        #};
       };
       programs = {
         git = {
@@ -86,7 +78,7 @@
               end
               nix shell $p
             '';
-            fish_command_not_found = "nix shell nixpkgs#(command-not-found $argv[1] &| sed -nr 's/.*-p (.*)$/\\1/p' | ${lib.getExe pkgs.fzf} || return 0) -c $argv[1]";
+            # fish_command_not_found = "nix shell nixpkgs#(command-not-found $argv[1] &| sed -nr 's/.*-p (.*)$/\\1/p' | ${lib.getExe pkgs.fzf} || return 0) -c $argv[1]";
           };
         };
         neovim = {
@@ -98,6 +90,14 @@
             set clipboard+=unnamedplus
           '';
         };
+
+        # nix-locate
+        command-not-found.enable = lib.mkForce false;
+        nix-index = {
+          enable = true;
+          enableFishIntegration = true;
+        };
+
         # gpg = {
         #   enable = true;
         #   mutableKeys = false;