summary refs log tree commit diff
path: root/mixins/cli.nix
diff options
context:
space:
mode:
Diffstat (limited to 'mixins/cli.nix')
-rw-r--r--mixins/cli.nix33
1 files changed, 16 insertions, 17 deletions
diff --git a/mixins/cli.nix b/mixins/cli.nix
index c5ff7b9..ca6d55d 100644
--- a/mixins/cli.nix
+++ b/mixins/cli.nix
@@ -7,7 +7,6 @@
 }: {
   imports = [
     inputs.home-manager.nixosModules."home-manager"
-    inputs.agenix.nixosModules
   ];
   config = {
     home-manager.users.tzlil = {pkgs, ...}@hm: {
@@ -17,23 +16,23 @@
           curl
           ripgrep
         ];
-        programs = {
-          ssh.enable = true;
-          git = {
-            userName = "tzlil";
-            userEmail = "tzlils@protonmail.com";
-            enable = true;
+      };
+      programs = {
+        ssh.enable = true;
+        git = {
+          userName = "tzlil";
+          userEmail = "tzlils@protonmail.com";
+          enable = true;
+        };
+        fish = {
+          enable = true;
+          shellAliases = {
+            gc = "git clone";
+            l = "ls -alh";
           };
-          fish = {
-            enable = true;
-            shellAliases = {
-              gc = "git clone";
-              l = "ls -alh";
-            };
-            functions = {
-              sb.body = "sudo nixos-rebuild build --flake ~/sources/nixcfg#(hostname)";
-              sw.body = "sudo nixos-rebuild switch --flake ~/sources/nixcfg#(hostname)";
-            };
+          functions = {
+            sb.body = "sudo nixos-rebuild build --flake ~/sources/nixcfg#(hostname)";
+            sw.body = "sudo nixos-rebuild switch --flake ~/sources/nixcfg#(hostname)";
           };
         };
       };