summary refs log tree commit diff
path: root/mixins/cli.nix
diff options
context:
space:
mode:
Diffstat (limited to 'mixins/cli.nix')
-rw-r--r--mixins/cli.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/mixins/cli.nix b/mixins/cli.nix
index 3dce0bf..9ce9ee4 100644
--- a/mixins/cli.nix
+++ b/mixins/cli.nix
@@ -18,6 +18,7 @@
           bat
           croc
         ];
+        sessionVariables.EDITOR = "nvim";
       };
       programs = {
         ssh.enable = true;
@@ -42,6 +43,11 @@
             sw.body = "nixos-rebuild switch --flake git+ssh://pc/home/tzlil/newflake --use-remote-sudo";
           };
         };
+        neovim = {
+          enable = true;
+          viAlias = true;
+          vimAlias = true;
+        };
       };
     };
   };