summary refs log tree commit diff
path: root/mixins/cli.nix
diff options
context:
space:
mode:
Diffstat (limited to 'mixins/cli.nix')
-rw-r--r--mixins/cli.nix13
1 files changed, 9 insertions, 4 deletions
diff --git a/mixins/cli.nix b/mixins/cli.nix
index db77ab8..84a5e3d 100644
--- a/mixins/cli.nix
+++ b/mixins/cli.nix
@@ -11,7 +11,7 @@
       config,
       nixosConfig,
       ...
-    } @ hm: {
+    }: {
       imports = [
         # inputs.viper-nix-common.homeModules.xdg
       ];
@@ -22,9 +22,14 @@
           ripgrep
           bat
           croc
-          (pkgs.python3.withPackages (ps: with ps; [
-            requests
-          ]))
+
+          # crap i need in my shell for general usage, mostly data science
+          (pkgs.python3.withPackages (ps:
+            with ps; [
+              requests
+              numpy
+              more-itertools
+            ]))
         ];
         sessionVariables = {
           EDITOR = "nvim";