summary refs log tree commit diff
path: root/mixins/cli.nix
diff options
context:
space:
mode:
Diffstat (limited to 'mixins/cli.nix')
-rw-r--r--mixins/cli.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/mixins/cli.nix b/mixins/cli.nix
index 8a37600..d4815e4 100644
--- a/mixins/cli.nix
+++ b/mixins/cli.nix
@@ -85,7 +85,7 @@
               end
               nix shell $p
             '';
-	    fish_command_not_found = "nix shell nixpkgs#(command-not-found $argv[1] &| sed -nr 's/.*-p (.*)$/\\1/p' | ${lib.getExe pkgs.fzf}) -c $argv[1]";
+	    fish_command_not_found = "nix shell nixpkgs#(command-not-found $argv[1] &| sed -nr 's/.*-p (.*)$/\\1/p' | ${lib.getExe pkgs.fzf} || return 0) -c $argv[1]";
           };
         };
         neovim = {