summary refs log tree commit diff
path: root/hosts/vps/matrix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/vps/matrix.nix')
-rw-r--r--hosts/vps/matrix.nix37
1 files changed, 21 insertions, 16 deletions
diff --git a/hosts/vps/matrix.nix b/hosts/vps/matrix.nix
index cb13326..2d606b0 100644
--- a/hosts/vps/matrix.nix
+++ b/hosts/vps/matrix.nix
@@ -1,23 +1,28 @@
-{ pkgs, config, ... }:
-
 {
+  pkgs,
+  config,
+  ...
+}: {
   config = {
     services.matrix-synapse = {
-        enable = true;
-        settings.server_name = config.networking.domain;
-        settings.listeners = [
-          { port = 8008;
-            bind_addresses = [ "::1" ];
-            type = "http";
-            tls = false;
-            x_forwarded = true;
-            resources = [ {
-              names = [ "client" "federation" ];
+      enable = true;
+      settings.server_name = config.networking.domain;
+      settings.listeners = [
+        {
+          port = 8008;
+          bind_addresses = ["::1"];
+          type = "http";
+          tls = false;
+          x_forwarded = true;
+          resources = [
+            {
+              names = ["client" "federation"];
               compress = true;
-            } ];
-          }
-        ];
+            }
+          ];
+        }
+      ];
     };
     networking.firewall.allowedTCPPorts = [80 443];
   };
-}
\ No newline at end of file
+}