summary refs log tree commit diff
path: root/hosts/vps/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/vps/default.nix')
-rw-r--r--hosts/vps/default.nix16
1 files changed, 14 insertions, 2 deletions
diff --git a/hosts/vps/default.nix b/hosts/vps/default.nix
index 7cd5f6c..d55a62e 100644
--- a/hosts/vps/default.nix
+++ b/hosts/vps/default.nix
@@ -10,10 +10,11 @@
     ../../mixins/cli.nix
     ./services/website.nix
     ./services/git.nix
-    ./services/hydrus.nix
+    # ./services/hydrus.nix
     ./services/matrix.nix
     ./services/maloja.nix
     ./services/arXiv.nix
+    ./services/cytube.nix
   ];
 
   config = {
@@ -66,10 +67,21 @@
       openFirewall = true;
     };
     services.factorio = {
-      enable = true;
+      enable = false;
       openFirewall = true;
       game-password = "???";
       requireUserVerification = false;
     };
+    security.lockKernelModules = lib.mkForce false;
+    virtualisation.podman = {
+      enable = true;
+      autoPrune.enable = true;
+      dockerCompat = true;
+      defaultNetwork.settings = {
+        # Required for container networking to be able to use names.
+        dns_enabled = true;
+      };
+    };
+    virtualisation.oci-containers.backend = "podman";
   };
 }