summary refs log tree commit diff
path: root/hosts/vm/cfg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/vm/cfg.nix')
-rw-r--r--hosts/vm/cfg.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/hosts/vm/cfg.nix b/hosts/vm/cfg.nix
index d6f33d9..4042ea0 100644
--- a/hosts/vm/cfg.nix
+++ b/hosts/vm/cfg.nix
@@ -6,14 +6,14 @@
     # ../../profiles/graphical.nix
     ../../mixins/tailscale.nix
     ../../mixins/cli.nix
-    # ../../mixins/greet.nix
+    ../../mixins/greet.nix
+    ../../mixins/hyprland.nix
     # ../../mixins/sway.nix
-    (modulesPath + "/profiles/qemu-guest.nix")
   ];
 
   config = {
     _module.args.nixinate = {
-      host = "100.109.155.123";
+      host = "vm";
       sshUser = "tzlil";
       buildOn = "remote"; # valid args are "local" or "remote"
       substituteOnTarget = true; # if buildOn is "local" then it will substitute on the target, "-s"
@@ -71,5 +71,7 @@
       enable = true;
       algorithm = "zstd";
     };
+
+    greeter.initialSession = "sh -c hyprland";
   };
 }
\ No newline at end of file