summary refs log tree commit diff
path: root/hosts/vm/cfg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/vm/cfg.nix')
-rw-r--r--hosts/vm/cfg.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/hosts/vm/cfg.nix b/hosts/vm/cfg.nix
new file mode 100644
index 0000000..1b17ea6
--- /dev/null
+++ b/hosts/vm/cfg.nix
@@ -0,0 +1,17 @@
+{config}: {
+  imports = [
+    "../profiles/core.nix"
+    "../profiles/user.nix"
+    "../mixins/tailscale.nix"
+  ]
+
+  config = {
+    boot.supportedFilesystems = ["9p"];
+    fileSystems."/flake" = {
+      fsType = "9p";
+      device = "host0";
+      options = ["_netdev"];
+    };
+    boot.kernelParams = [ "console=ttyS0" ];
+  };
+}
\ No newline at end of file