summary refs log tree commit diff
path: root/hosts/disko.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/disko.nix')
-rw-r--r--hosts/disko.nix56
1 files changed, 0 insertions, 56 deletions
diff --git a/hosts/disko.nix b/hosts/disko.nix
deleted file mode 100644
index 26d1849..0000000
--- a/hosts/disko.nix
+++ /dev/null
@@ -1,56 +0,0 @@
-# Example to create a bios compatible gpt partition
-{
-  lib,
-  disks,
-  ...
-}: {
-  disk = lib.genAttrs disks (dev: {
-    device = dev;
-    type = "disk";
-    content = {
-      type = "table";
-      format = "gpt";
-      partitions = [
-        {
-          type = "partition";
-          name = "boot";
-          start = "1MiB";
-          end = "100MiB";
-          bootable = true;
-          content = {
-            type = "filesystem";
-            format = "vfat";
-            mountpoint = "/boot";
-          };
-        }
-        {
-          name = "nix";
-          type = "partition";
-          start = "128MiB";
-          end = "100%";
-          content = {
-            type = "btrfs";
-            extraArgs = "-f"; # Override existing partition
-            subvolumes = {
-              "/" = {
-                mountOptions = ["noatime" "compress=zstd"];
-              };
-            };
-          };
-        }
-      ];
-    };
-  });
-
-  nodev = {
-    "/" = {
-      fsType = "tmpfs";
-      mountOptions = [
-        "noexec"
-        "defaults"
-        "size=2G"
-        "mode=755"
-      ];
-    };
-  };
-}