summary refs log tree commit diff
path: root/hosts/disko.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/disko.nix')
-rw-r--r--hosts/disko.nix49
1 files changed, 49 insertions, 0 deletions
diff --git a/hosts/disko.nix b/hosts/disko.nix
new file mode 100644
index 0000000..0a0710e
--- /dev/null
+++ b/hosts/disko.nix
@@ -0,0 +1,49 @@
+# Example to create a bios compatible gpt partition
+{ lib, disks, ... }: {
+  disk = lib.genAttrs disks (dev: {
+    device = dev;
+    type = "disk";
+    content = {
+      type = "table";
+      format = "gpt";
+      partitions = [
+        {
+          type = "partition";
+          name = "boot";
+          start = "1MiB";
+          end = "100MiB";
+          bootable = true;
+          content = {
+            type = "filesystem";
+            format = "vfat";
+            mountpoint = "/boot";
+          };
+        }
+        {
+          name = "nix";
+          type = "partition";
+          start = "128MiB";
+          end = "100%";
+          content = {
+            type = "btrfs";
+            extraArgs = "-f"; # Override existing partition
+            subvolumes = {
+              "/nix" = {
+                mountOptions = ["noatime" "compress=zstd"]
+              }
+            };
+          };
+        }
+      ]
+    };
+  });
+    
+  nodev = {
+    "/" = {
+      fsType = "tmpfs";
+      mountOptions = [
+        "size=200M"
+      ];
+    };
+  };
+}
\ No newline at end of file