summary refs log tree commit diff
path: root/hosts/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/default.nix')
-rw-r--r--hosts/default.nix22
1 files changed, 21 insertions, 1 deletions
diff --git a/hosts/default.nix b/hosts/default.nix
index 164030c..1367391 100644
--- a/hosts/default.nix
+++ b/hosts/default.nix
@@ -7,7 +7,7 @@ inputs: let
         ../profiles/security.nix
         ../profiles/ssh.nix
         ../profiles/network.nix
-	../profiles/impermanence.nix
+        ../profiles/impermanence.nix
       ];
     }
     inputs.agenix.nixosModules.age
@@ -32,6 +32,11 @@ inputs: let
       hermetic = false;
     };
   };
+
+  stateVersion = v: {
+    home-manager.users.tzlil.home.stateVersion = v;
+    system.stateVersion = v;
+  };
 in {
   navi = inputs.nixpkgs.lib.nixosSystem {
     system = "x86_64-linux";
@@ -41,6 +46,21 @@ in {
         "${inputs.self}/hosts/navi"
         {networking.hostName = "navi";}
         (nixinate "navi")
+        (stateVersion "23.11")
+      ]
+      ++ commonProfiles
+      ++ commonHome;
+  };
+
+  vps = inputs.nixpkgs.lib.nixosSystem {
+    system = "x86_64-linux";
+    specialArgs = {inherit inputs;};
+    modules =
+      [
+        "${inputs.self}/hosts/vps"
+        {networking.hostName = "vps";}
+        (nixinate "vps")
+        (stateVersion "22.05")
       ]
       ++ commonProfiles
       ++ commonHome;