summary refs log tree commit diff
path: root/profiles/network.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-01-21 17:34:49 +0200
committertzlil <tzlils@protonmail.com>2023-01-21 17:34:49 +0200
commitd9317de584c66b068a336889aa9adc3ac3837e5e (patch)
treef9418f271c8e9bdc2cc6075de471bc4b7049f965 /profiles/network.nix
parent5aa3d1eb375f7d67b717f0306752bd974fce1fbc (diff)
change deploy-rs to nixinate, change user to use passwordFile, add password age secret, remove NetworkManager-wait-online.service
Diffstat (limited to 'profiles/network.nix')
-rw-r--r--profiles/network.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/profiles/network.nix b/profiles/network.nix
index 0ba325b..1b3026b 100644
--- a/profiles/network.nix
+++ b/profiles/network.nix
@@ -22,6 +22,13 @@
         '';
     };
 
+    # Don't wait for network startup
+    # https://old.reddit.com/r/NixOS/comments/vdz86j/how_to_remove_boot_dependency_on_network_for_a
+    systemd = {
+      targets.network-online.wantedBy = pkgs.lib.mkForce []; # Normally ["multi-user.target"]
+      services.NetworkManager-wait-online.wantedBy = pkgs.lib.mkForce []; # Normally ["network-online.target"]
+    };
+
     services.dnscrypt-proxy2 = {
       enable = true;
       settings = {