summary refs log tree commit diff
path: root/profiles/network.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2022-12-13 02:15:50 +0200
committertzlil <tzlils@protonmail.com>2022-12-13 02:15:50 +0200
commit24637dfdfdd6dc8d116542f16a07d808c9e43c36 (patch)
tree369b5fb04e408604d481984b35aa02523217dbfd /profiles/network.nix
first commit
Diffstat (limited to 'profiles/network.nix')
-rw-r--r--profiles/network.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/profiles/network.nix b/profiles/network.nix
new file mode 100644
index 0000000..5aee7a1
--- /dev/null
+++ b/profiles/network.nix
@@ -0,0 +1,19 @@
+{ pkgs, lib, config, inputs, ... }:
+
+{
+  imports = [];
+  config = {
+    networking = {
+      firewall = {
+        enable = true;
+        allowPing = false;
+        allowedTCPPorts = [];
+        checkReversePath = "loose";
+      };
+      networkmanager.enable = true;
+      useDHCP = false;
+      nameservers = ["127.0.0.1" "::1"];
+      networkmanager.dns = "none";
+    };
+  };
+}
\ No newline at end of file