summary refs log tree commit diff
path: root/profiles/core.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-05-18 19:47:05 +0300
committertzlil <tzlils@protonmail.com>2023-05-18 19:47:05 +0300
commitebbace8f892f0cae46cce1211efd927066a012f8 (patch)
tree0e64d16c883e2327fcc4fe1797544c2a69c6b77e /profiles/core.nix
parent959dfaaeb7ae01a77f9e2c3c17bac1b7e23d8ea1 (diff)
parenta01a6fbdfcf923b1c9fa55c7bec0617c230e8e67 (diff)
merge
Diffstat (limited to 'profiles/core.nix')
-rw-r--r--profiles/core.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/profiles/core.nix b/profiles/core.nix
index 5f29653..f81ead8 100644
--- a/profiles/core.nix
+++ b/profiles/core.nix
@@ -32,5 +32,16 @@
 
     # save uid/guid
     environment.persistence."/nix/persist".directories = ["/var/lib/nixos"];
+
+    boot = {
+      tmp.cleanOnBoot = true;
+      kernelParams = [
+        "init_on_free=1"
+        "page_poison=1"
+        "page_alloc.shuffle=1"
+        "slab_nomerge"
+        "vsyscall=none"
+      ];
+    };
   };
 }