summary refs log tree commit diff
path: root/mixins/hyprland.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-03-12 16:29:17 +0200
committertzlil <tzlils@protonmail.com>2023-03-12 16:29:17 +0200
commit39eb0b807403c7745c2edc6024e0e713155662bc (patch)
tree7aca56baa092ecf5f58b6c2e4d597d613cca196b /mixins/hyprland.nix
parentf266d1b0d7c2f9c5c285af539fefe8d5ac96c479 (diff)
bunch of stuff
Diffstat (limited to 'mixins/hyprland.nix')
-rw-r--r--mixins/hyprland.nix27
1 files changed, 18 insertions, 9 deletions
diff --git a/mixins/hyprland.nix b/mixins/hyprland.nix
index 3442438..3cc740c 100644
--- a/mixins/hyprland.nix
+++ b/mixins/hyprland.nix
@@ -5,16 +5,25 @@
   inputs,
   ...
 }: {
-  imports = [
-    inputs.hyprland.nixosModules.default
-  ];
   config = {
-    programs.hyprland = {
-      enable = true;
-      xwayland = {
-        enable = false;
-        hidpi = false;
-      };
+    home-manager.users.tzlil = {
+      pkgs,
+      config,
+      nixosConfig,
+      ...
+    } @ hm: {
+      imports = [
+        inputs.hyprland.homeManagerModules.default
+      ];
+
+      wayland.windowManager.hyprland.enable = true;
     };
+    # programs.hyprland = {
+    #   enable = true;
+    #   xwayland = {
+    #     enable = false;
+    #     hidpi = false;
+    #   };
+    # };
   };
 }