summary refs log tree commit diff
path: root/mixins/cli.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-05-16 20:44:21 +0300
committertzlil <tzlils@protonmail.com>2023-05-16 20:44:21 +0300
commit57cbc3ac65272242bfee162b916d9675935e9c2e (patch)
tree0f6a3d99bfc1dbcda9eabcb71fb897fea73f09a0 /mixins/cli.nix
parent583dd2ebccd5a5144a6289ccc1adef3a0789637e (diff)
networkmanager is annoying me and nothing else works, need to fix dns
Diffstat (limited to 'mixins/cli.nix')
-rw-r--r--mixins/cli.nix13
1 files changed, 9 insertions, 4 deletions
diff --git a/mixins/cli.nix b/mixins/cli.nix
index db77ab8..84a5e3d 100644
--- a/mixins/cli.nix
+++ b/mixins/cli.nix
@@ -11,7 +11,7 @@
       config,
       nixosConfig,
       ...
-    } @ hm: {
+    }: {
       imports = [
         # inputs.viper-nix-common.homeModules.xdg
       ];
@@ -22,9 +22,14 @@
           ripgrep
           bat
           croc
-          (pkgs.python3.withPackages (ps: with ps; [
-            requests
-          ]))
+
+          # crap i need in my shell for general usage, mostly data science
+          (pkgs.python3.withPackages (ps:
+            with ps; [
+              requests
+              numpy
+              more-itertools
+            ]))
         ];
         sessionVariables = {
           EDITOR = "nvim";