summary refs log tree commit diff
path: root/hosts/vps/matrix.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-02-16 16:40:26 +0200
committertzlil <tzlils@protonmail.com>2023-02-16 16:40:26 +0200
commitd4896b353eed0ab37cf8a2591fe1f5369c37883f (patch)
tree267fcc685ce9efa2db60e51c772ef58ccfe6d330 /hosts/vps/matrix.nix
parent566dc1e8f6e619f590f017a810a8a55d9a90a25c (diff)
stuff
Diffstat (limited to 'hosts/vps/matrix.nix')
-rw-r--r--hosts/vps/matrix.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/hosts/vps/matrix.nix b/hosts/vps/matrix.nix
new file mode 100644
index 0000000..cb13326
--- /dev/null
+++ b/hosts/vps/matrix.nix
@@ -0,0 +1,23 @@
+{ pkgs, config, ... }:
+
+{
+  config = {
+    services.matrix-synapse = {
+        enable = true;
+        settings.server_name = config.networking.domain;
+        settings.listeners = [
+          { port = 8008;
+            bind_addresses = [ "::1" ];
+            type = "http";
+            tls = false;
+            x_forwarded = true;
+            resources = [ {
+              names = [ "client" "federation" ];
+              compress = true;
+            } ];
+          }
+        ];
+    };
+    networking.firewall.allowedTCPPorts = [80 443];
+  };
+}
\ No newline at end of file