summary refs log tree commit diff
path: root/hosts/vps/matrix.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-02-17 17:46:47 +0200
committertzlil <tzlils@protonmail.com>2023-02-17 17:46:47 +0200
commit222c7e35d7e9507f6eb8d67bb7af3ef9e623d0f3 (patch)
tree9b7f8ba8debdca1c2ca3739844d0fe4b3113209e /hosts/vps/matrix.nix
parent3c3e4531dac7f4ab591bf391be72a11121b45673 (diff)
added alejandra as formatter and formatted everything
Diffstat (limited to 'hosts/vps/matrix.nix')
-rw-r--r--hosts/vps/matrix.nix37
1 files changed, 21 insertions, 16 deletions
diff --git a/hosts/vps/matrix.nix b/hosts/vps/matrix.nix
index cb13326..2d606b0 100644
--- a/hosts/vps/matrix.nix
+++ b/hosts/vps/matrix.nix
@@ -1,23 +1,28 @@
-{ pkgs, config, ... }:
-
 {
+  pkgs,
+  config,
+  ...
+}: {
   config = {
     services.matrix-synapse = {
-        enable = true;
-        settings.server_name = config.networking.domain;
-        settings.listeners = [
-          { port = 8008;
-            bind_addresses = [ "::1" ];
-            type = "http";
-            tls = false;
-            x_forwarded = true;
-            resources = [ {
-              names = [ "client" "federation" ];
+      enable = true;
+      settings.server_name = config.networking.domain;
+      settings.listeners = [
+        {
+          port = 8008;
+          bind_addresses = ["::1"];
+          type = "http";
+          tls = false;
+          x_forwarded = true;
+          resources = [
+            {
+              names = ["client" "federation"];
               compress = true;
-            } ];
-          }
-        ];
+            }
+          ];
+        }
+      ];
     };
     networking.firewall.allowedTCPPorts = [80 443];
   };
-}
\ No newline at end of file
+}